English Forum Switzerland

English Forum Switzerland (https://www.englishforum.ch/forum.php)
-   Forum support (https://www.englishforum.ch/forum-support/)
-   -   Invalid thread after Reply (https://www.englishforum.ch/forum-support/1132-invalid-thread-after-reply.html)

Guest 25.08.2006 11:39

Invalid thread after Reply
 
When submitting a post to a thread, I often get a log-in screen even though I am already logged in. And after entering my username and password, I get an "invalid thread" error. Anyone else get this?

I'm using Safaria on MacOS 10.4.6.

Nickers 25.08.2006 11:57

Re: Invalid thread after Reply
 
Quote:

Originally Posted by Phos
When submitting a post to a thread, I often get a log-in screen even though I am already logged in. And after entering my username and password, I get an "invalid thread" error. Anyone else get this?

I'm using Safaria on MacOS 10.4.6.

I'm using safari on 10.4.6 also and never had such problem?

Lob 25.08.2006 12:02

Re: Invalid thread after Reply
 
what's your cookie settings present set to?

Guest 25.08.2006 12:05

Re: Invalid thread after Reply
 
It's set to "Only from sites you navigate to".

Guest 25.08.2006 12:06

Re: Invalid thread after Reply
 
I'll try it again...

Lob 25.08.2006 12:12

Re: Invalid thread after Reply
 
ok, you're rejecting third-party cookies...that's fairly normal (I do it) and the forum should work with that set.

Worst case would be to clear the cookie for this site and start over. Also - do you subscribe to threads when you're posting?

Guest 25.08.2006 12:28

Re: Invalid thread after Reply
 
[Posting reply after waiting 15 mintes with reply form open. Checking to see if defect is related to some timeout setting]

Lob 25.08.2006 12:29

Re: Invalid thread after Reply
 
Quote:

Originally Posted by Phos
[Posting reply after waiting 15 mintes with reply form open. Checking to see if defect is related to some timeout setting]

...don't think so, session-based authentication is not used - it's cookie-based...

Guest 25.08.2006 12:38

Re: Invalid thread after Reply
 
Ah, I think I got the test case.

-View a thread
-Open another window
-Click "Reply" to go to Reply Form.
-Switch to other window and navigate to another thread
-Switch to Reply form, write something and post.
+(Displays Log-in screen)
+(Displays Welcome)
+(Displays Error Message: "Invalid Thread specified. If you followed a valid link, please notify the administration")

I have a screenshot of this if needed. Perhaps it's tracking the current thread ID in a session variable instead of the reply form.

Lob 25.08.2006 12:47

Re: Invalid thread after Reply
 
are you logged-in before opening the new window?

Guest 25.08.2006 12:49

Re: Invalid thread after Reply
 
Yes...
Ah, a three letter reply is not allowed.

Lob 25.08.2006 12:52

Re: Invalid thread after Reply
 
I would assume that MacOS is treating the second window as a child and all cookies and session variables should be valid....having not used Safari, I don't know if this is the case.

Safari options - are there any for spawned windows?

Mark's back in a day or two and might have an idea about this.

You could also use Firefox on your mac, of course ;)

Guest 25.08.2006 12:54

Re: Invalid thread after Reply
 
So when this happens, I have to:
-back up to the reply form
-copy the text I entered
-go back to the thread
-click Reply button
-paste text into the reply form and submit.

Easy enough for me. But I wonder if this might put off less patient users from posting.

Guest 25.08.2006 12:57

Re: Invalid thread after Reply
 
It's not a show-stopper. I wouldn't switch to Firefox just for this defect. Although Opera has some cool tricks. But I'll tell you what, I try this on various platforms and browsers and report on the behavior. As my Netizen duty.

mark 27.08.2006 10:51

Re: Invalid thread after Reply
 
Quote:

Originally Posted by Phos
It's not a show-stopper. I wouldn't switch to Firefox just for this defect. Although Opera has some cool tricks. But I'll tell you what, I try this on various platforms and browsers and report on the behavior. As my Netizen duty.

Hi Phos, never heard of this before - but it would be a good idea to try in another browser to see if it is related to your browser - would save us having to guess :)

Guest 29.08.2006 08:22

Re: Invalid thread after Reply
 
Looks like this problem is only Safari 2.0.3/MacOS 10.4.6. It does not appear in 3 other Mac browsers.

If no one else is complaining, then it's possible I have a bad installation. But if it comes up again, I can help triangulate on this defect.

Guest 01.09.2006 09:09

"invalid thread link"
 
Read a topic, hit reply, got distracted, came back twenty minutes later, wrote reply, clicked 'submit reply', was asked to log on again, the got the error message.

Apperently the post was accepted.

Nothing to cry about but thought you might want to know...

Stu

mark 01.09.2006 10:47

Re: "invalid thread link"
 
Could also be if the thread was moved the meantime? We are often moving threads posted in the incorrect area - this might cause this.

Could this me the same issue as "invalid thread after reply" posted just a couple of threads down, also in the support area? If so, a merge might be in order - see comment in paragraph above :)


All times are GMT +2. The time now is 08:56.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.1.0