Go Back   English Forum Switzerland > Support > Support > Forum support  
Reply
 
Thread Tools Display Modes
  #1  
Old 25.08.2006, 11:39
Guest
 
Posts: n/a
Invalid thread after Reply

When submitting a post to a thread, I often get a log-in screen even though I am already logged in. And after entering my username and password, I get an "invalid thread" error. Anyone else get this?

I'm using Safaria on MacOS 10.4.6.
Reply With Quote
  #2  
Old 25.08.2006, 11:57
Nickers's Avatar
Forum Legend
 
Join Date: May 2006
Location: Zurich
Posts: 3,735
Groaned at 41 Times in 35 Posts
Thanked 4,899 Times in 1,697 Posts
Nickers has a reputation beyond reputeNickers has a reputation beyond reputeNickers has a reputation beyond reputeNickers has a reputation beyond reputeNickers has a reputation beyond reputeNickers has a reputation beyond repute
Re: Invalid thread after Reply

Quote:
When submitting a post to a thread, I often get a log-in screen even though I am already logged in. And after entering my username and password, I get an "invalid thread" error. Anyone else get this?

I'm using Safaria on MacOS 10.4.6.
I'm using safari on 10.4.6 also and never had such problem?
Reply With Quote
  #3  
Old 25.08.2006, 12:02
Lob's Avatar
Lob Lob is offline
Forum Legend
 
Join Date: Nov 2005
Location: -
Posts: 7,814
Groaned at 45 Times in 40 Posts
Thanked 1,973 Times in 1,060 Posts
Lob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond repute
Re: Invalid thread after Reply

what's your cookie settings present set to?
Reply With Quote
  #4  
Old 25.08.2006, 12:05
Guest
 
Posts: n/a
Re: Invalid thread after Reply

It's set to "Only from sites you navigate to".
Reply With Quote
  #5  
Old 25.08.2006, 12:06
Guest
 
Posts: n/a
Re: Invalid thread after Reply

I'll try it again...
Reply With Quote
  #6  
Old 25.08.2006, 12:12
Lob's Avatar
Lob Lob is offline
Forum Legend
 
Join Date: Nov 2005
Location: -
Posts: 7,814
Groaned at 45 Times in 40 Posts
Thanked 1,973 Times in 1,060 Posts
Lob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond repute
Re: Invalid thread after Reply

ok, you're rejecting third-party cookies...that's fairly normal (I do it) and the forum should work with that set.

Worst case would be to clear the cookie for this site and start over. Also - do you subscribe to threads when you're posting?
Reply With Quote
  #7  
Old 25.08.2006, 12:28
Guest
 
Posts: n/a
Re: Invalid thread after Reply

[Posting reply after waiting 15 mintes with reply form open. Checking to see if defect is related to some timeout setting]
Reply With Quote
  #8  
Old 25.08.2006, 12:29
Lob's Avatar
Lob Lob is offline
Forum Legend
 
Join Date: Nov 2005
Location: -
Posts: 7,814
Groaned at 45 Times in 40 Posts
Thanked 1,973 Times in 1,060 Posts
Lob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond repute
Re: Invalid thread after Reply

Quote:
[Posting reply after waiting 15 mintes with reply form open. Checking to see if defect is related to some timeout setting]
...don't think so, session-based authentication is not used - it's cookie-based...
Reply With Quote
  #9  
Old 25.08.2006, 12:38
Guest
 
Posts: n/a
Re: Invalid thread after Reply

Ah, I think I got the test case.

-View a thread
-Open another window
-Click "Reply" to go to Reply Form.
-Switch to other window and navigate to another thread
-Switch to Reply form, write something and post.
+(Displays Log-in screen)
+(Displays Welcome)
+(Displays Error Message: "Invalid Thread specified. If you followed a valid link, please notify the administration")

I have a screenshot of this if needed. Perhaps it's tracking the current thread ID in a session variable instead of the reply form.
Reply With Quote
  #10  
Old 25.08.2006, 12:47
Lob's Avatar
Lob Lob is offline
Forum Legend
 
Join Date: Nov 2005
Location: -
Posts: 7,814
Groaned at 45 Times in 40 Posts
Thanked 1,973 Times in 1,060 Posts
Lob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond repute
Re: Invalid thread after Reply

are you logged-in before opening the new window?
Reply With Quote
  #11  
Old 25.08.2006, 12:49
Guest
 
Posts: n/a
Re: Invalid thread after Reply

Yes...
Ah, a three letter reply is not allowed.
Reply With Quote
  #12  
Old 25.08.2006, 12:52
Lob's Avatar
Lob Lob is offline
Forum Legend
 
Join Date: Nov 2005
Location: -
Posts: 7,814
Groaned at 45 Times in 40 Posts
Thanked 1,973 Times in 1,060 Posts
Lob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond reputeLob has a reputation beyond repute
Re: Invalid thread after Reply

I would assume that MacOS is treating the second window as a child and all cookies and session variables should be valid....having not used Safari, I don't know if this is the case.

Safari options - are there any for spawned windows?

Mark's back in a day or two and might have an idea about this.

You could also use Firefox on your mac, of course
Reply With Quote
  #13  
Old 25.08.2006, 12:54
Guest
 
Posts: n/a
Re: Invalid thread after Reply

So when this happens, I have to:
-back up to the reply form
-copy the text I entered
-go back to the thread
-click Reply button
-paste text into the reply form and submit.

Easy enough for me. But I wonder if this might put off less patient users from posting.
Reply With Quote
  #14  
Old 25.08.2006, 12:57
Guest
 
Posts: n/a
Re: Invalid thread after Reply

It's not a show-stopper. I wouldn't switch to Firefox just for this defect. Although Opera has some cool tricks. But I'll tell you what, I try this on various platforms and browsers and report on the behavior. As my Netizen duty.
Reply With Quote
  #15  
Old 27.08.2006, 10:51
mark's Avatar
The Architect
 
Join Date: May 2005
Location: Zollikon, Switzerland
Posts: 3,070
Groaned at 3 Times in 3 Posts
Thanked 418 Times in 115 Posts
mark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond repute
Re: Invalid thread after Reply

Quote:
It's not a show-stopper. I wouldn't switch to Firefox just for this defect. Although Opera has some cool tricks. But I'll tell you what, I try this on various platforms and browsers and report on the behavior. As my Netizen duty.
Hi Phos, never heard of this before - but it would be a good idea to try in another browser to see if it is related to your browser - would save us having to guess
Reply With Quote
  #16  
Old 29.08.2006, 08:22
Guest
 
Posts: n/a
Re: Invalid thread after Reply

Looks like this problem is only Safari 2.0.3/MacOS 10.4.6. It does not appear in 3 other Mac browsers.

If no one else is complaining, then it's possible I have a bad installation. But if it comes up again, I can help triangulate on this defect.
Reply With Quote
  #17  
Old 01.09.2006, 09:09
stuinzuri's Avatar
Member
 
Join Date: Apr 2006
Location: Zürich-->San Francisco
Posts: 166
Groaned at 3 Times in 1 Post
Thanked 12 Times in 6 Posts
stuinzuri has earned some respectstuinzuri has earned some respect
"invalid thread link"

Read a topic, hit reply, got distracted, came back twenty minutes later, wrote reply, clicked 'submit reply', was asked to log on again, the got the error message.

Apperently the post was accepted.

Nothing to cry about but thought you might want to know...

Stu
Reply With Quote
  #18  
Old 01.09.2006, 10:47
mark's Avatar
The Architect
 
Join Date: May 2005
Location: Zollikon, Switzerland
Posts: 3,070
Groaned at 3 Times in 3 Posts
Thanked 418 Times in 115 Posts
mark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond reputemark has a reputation beyond repute
Re: "invalid thread link"

Could also be if the thread was moved the meantime? We are often moving threads posted in the incorrect area - this might cause this.

Could this me the same issue as "invalid thread after reply" posted just a couple of threads down, also in the support area? If so, a merge might be in order - see comment in paragraph above
Reply With Quote
Reply




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT +2. The time now is 04:40.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.1.0